IonCube Loader is an instrument, which is required to run files which are protected with ionCube PHP Encoder. The latter is an application employed to make PHP code human unreadable, to protect it from reverse engineering and / or unauthorized usage. Various script-driven applications, particularly discussion forums, content management systems and electronic commerce solutions are encrypted with ionCube PHP Encoder, which means that when you get a script and you find that ionCube is on the list of hosting environment prerequisites, you should make sure that your website hosting server has the instrument pre-installed. While it is not that hard to set it up if you have your own server, it is almost impossible to do that on a shared hosting server for the reason that the PHP environment will have to be precompiled and all of the clients on the server will be affected.

IonCube in Shared Website Hosting

IonCube Loader comes with all of the shared website hosting plans that we supply, so any time you require it in order to install and run some script app which requires it, you can enable it with a click in the Advanced area of the Hepsia Control Panel. Since you can switch the PHP version that is active for your account from the same section, you need to enable the tool for every new version that you set. When you are more skillful, you are able to employ a php.ini file in a domain or subdomain folder and set the PHP version as well as the status of ionCube Loader for that particular site only, without affecting the entire account. In this way you are able to run both new and older script apps for multiple websites inside the same account - a thing that you won't be able to do with various other website hosting providers on the market.

IonCube in Semi-dedicated Hosting

If you aquire a semi-dedicated server plan from our company, you can take advantage of any kind of script-driven application that needs ionCube Loader since the tool comes with all the servers that are a part of our advanced cloud website hosting platform. In addition, we support multiple releases of PHP, and if you move from PHP 4 to 5.2 or 5.3, for example, you can enable ionCube for this particular release with just a click from your Hepsia Control Panel. Our platform will remember your choice, so if you switch back to the previous release of PHP, the instrument will already be active. For more tech-savvy users, we also offer the option to pick the PHP version and whether ionCube will be active or not for a specific domain name without altering the settings for the whole web hosting account. This can be done by placing a php.ini file within a domain folder with a few lines of code.